Projects
Eulaceura:Mainline
python-certbot
_service:obs_scm:python-certbot.spec
Sign Up
Log In
Username
Password
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File _service:obs_scm:python-certbot.spec of Package python-certbot
Name: python-certbot Version: 2.11.0 Release: 1 Summary: ACME client License: MIT and Apache-2.0 URL: https://github.com/certbot/certbot Source0: https://github.com/certbot/certbot/archive/refs/tags/v%{version}.tar.gz Source10: certbot-renew-systemd.service Source11: certbot-renew-systemd.timer Source12: certbot-sysconfig-certbot Source13: certbot-cli.ini Source15: certbot.logrotate BuildArch: noarch %description The python3 libraries to interface with certbot. %package -n certbot Summary: A free, automated certificate authority client Requires: python3-certbot = %{version}-%{release} %{?systemd_requires} %description -n certbot certbot is a free, automated certificate authority that aims to lower the barriers to entry for encrypting all HTTP traffic on the internet. %package -n python3-certbot Summary: ACME client Provides: python-certbot = %{version}-%{release} BuildRequires: python3-devel BuildRequires: python3-setuptools Requires: python3-acme = %{version}-%{release} Requires: python3-ConfigArgParse Requires: python3-configobj Requires: python3-cryptography Requires: python3-distro Requires: python3-josepy Requires: python-parsedatetime Requires: python3-pyrfc3339 Requires: python3-pytz Requires: python3-zope-component Requires: python3-zope-interface %description -n python3-certbot The python3 libraries to interface with certbot %package -n python3-acme Summary:ACME protocol implementation in Python Provides:python-acme = %{version}-%{release} BuildRequires: python3-devel BuildRequires: python3-setuptools %description -n python3-acme Python libraries implementing the Automatic Certificate Management Environment (ACME)protocol.it is used by the Let's Encrypt project. %package -n python3-certbot-apache Summary: The apache plugin for certbot Requires: mod_ssl Requires: python3-acme = %{version}-%{release} Requires: python3-certbot = %{version}-%{release} Provides: certbot-apache = %{version}-%{release} %description -n python3-certbot-apache Plugin for certbot that allows for automatic configuration of apache %package -n python3-certbot-nginx Summary: The nginx plugin for certbot Provides: certbot-nginx = %{version}-%{release} Requires: python3-acme = %{version}-%{release} Requires: python3-certbot = %{version}-%{release} %description -n python3-certbot-nginx Plugin for certbot that allows for automatic configuration of ngnix %package help Summary: Development documents and examples for certbot Provides: python3-certbot-doc = %{version}-%{release} %description help The python3 libraries to interface with certbot %prep %autosetup -n certbot-%{version} -p1 %build for module in acme certbot certbot-apache certbot-nginx do pushd $module %py3_build popd done %install for module in acme certbot certbot-apache certbot-nginx do pushd $module %py3_install popd done mv %{buildroot}%{_bindir}/certbot{,-3} ln -s certbot-3 %{buildroot}%{_bindir}/certbot install -d -m755 %{buildroot}/%{_pkgdocdir} cd ./certbot if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}/certbot; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}/certbot; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}/certbot; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}/certbot; fi cd ./../acme if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}/acme; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}/acme; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}/acme; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}/acme; fi install -Dm 0644 --preserve-timestamps %{S:10} %{buildroot}%{_unitdir}/certbot-renew.service install -Dm 0644 --preserve-timestamps %{S:11} %{buildroot}%{_unitdir}/certbot-renew.timer install -Dm 0644 --preserve-timestamps %{S:12} %{buildroot}%{_sysconfdir}/sysconfig/certbot install -Dm 0644 --preserve-timestamps %{S:13} %{buildroot}%{_sysconfdir}/letsencrypt/cli.ini install -Dm 0644 --preserve-timestamps %{S:15} %{buildroot}%{_sysconfdir}/logrotate.d/certbot # project uses old letsencrypt dir for compatibility install -dm 0755 %{buildroot}%{_sysconfdir}/letsencrypt install -dm 0755 %{buildroot}%{_sharedstatedir}/letsencrypt install -dm 0755 %{buildroot}%{_localstatedir}/log/letsencrypt %post -n certbot %systemd_post certbot-renew.timer # Remind users to start certbot-renew.timer if they need certbot to automatically renew certs if [ "$1" -eq 1 ] ; then echo "" echo "Certbot auto renewal timer is not started by default." echo "Run 'systemctl start certbot-renew.timer' to enable automatic renewals." fi %preun -n certbot %systemd_preun certbot-renew.timer %postun -n certbot %systemd_postun certbot-renew.timer %files -n certbot %license LICENSE.txt %doc certbot/README.rst %{_bindir}/certbot %dir %{_sysconfdir}/letsencrypt %dir %{_sharedstatedir}/letsencrypt %dir %{_localstatedir}/log/letsencrypt %config(noreplace) %{_sysconfdir}/letsencrypt/cli.ini %config(noreplace) %{_sysconfdir}/sysconfig/certbot %config(noreplace) %{_sysconfdir}/logrotate.d/certbot %{_unitdir}/certbot-renew.service %{_unitdir}/certbot-renew.timer %files -n python3-certbot %license certbot/LICENSE.txt %doc certbot/README.rst %{python3_sitelib}/certbot %{python3_sitelib}/certbot-%{version}-py%{python3_version}.egg-info %{_bindir}/certbot-3 %files help %{_docdir}/* %files -n python3-acme %license acme/LICENSE.txt %doc acme/README.rst %{python3_sitelib}/acme %{python3_sitelib}/acme-%{version}-py%{python3_version}.egg-info %files -n python3-certbot-apache %license certbot-apache/LICENSE.txt %doc certbot-apache/README.rst %{python3_sitelib}/certbot_apache/ %{python3_sitelib}/certbot_apache-%{version}-py%{python3_version}.egg-info %files -n python3-certbot-nginx %license certbot-nginx/LICENSE.txt %doc certbot-nginx/README.rst %{python3_sitelib}/certbot_nginx/ %{python3_sitelib}/certbot_nginx-%{version}-py%{python3_version}.egg-info %changelog * Tue Oct 01 2024 Funda Wang <fundawang@yeah.net> - 2.11.0-1 - Update package to version 2.11.0 - add apache and nginx module - add systemd timer and logrotate conf * Fri Feb 23 2024 chendexi <chendexi@kylinos.cn> - 2.9.0-1 - Update package to version 2.9.0 * Tue Nov 21 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 2.7.4-1 - Update package to version 2.7.4 * Wed Jul 05 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 2.6.0-1 - Update package to version 2.6.0 * Fri Apr 07 2023 wangkai <13474090681@163.com> - 2.5.0-1 - Update to 2.5.0 * Fri May 20 2022 liukuo <liukuo@kylinos.cn> - 1.16.0-4 - License compliance rectification * Fri May 06 2022 yangping <yangping69@h-partners.com> - 1.16.0-3 - Fix build error caused by py3.10+ wildcard * Thu Aug 05 2021 xu_ping <xuping33@huawei.com> - 1.16.0-2 - fix sync code to openEuler-20.03-LTS-SP1 %file error. * Mon Jun 28 2021 Python_Bot <Python_Bot@openeuler.org> - 1.16.0-1 - Package Spec generated
Locations
Projects
Search
Status Monitor
Help
Open Build Service
OBS Manuals
API Documentation
OBS Portal
Reporting a Bug
Contact
Mailing List
Forums
Chat (IRC)
Twitter
Open Build Service (OBS)
is an
openSUSE project
.
浙ICP备2022010568号-2