Projects
home:Eustace:branches:Eulaceura:Factory
python-XlsxWriter
_service:obs_scm:python-XlsxWriter.spec
Sign Up
Log In
Username
Password
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File _service:obs_scm:python-XlsxWriter.spec of Package python-XlsxWriter
%global _empty_manifest_terminate_build 0 Name: python-XlsxWriter Version: 3.2.0 Release: 1 Summary: A Python module for creating Excel XLSX files. License: BSD-2-Clause URL: https://github.com/jmcnamara/XlsxWriter Source0: %{pypi_source XlsxWriter} BuildArch: noarch %description **XlsxWriter** is a Python module for writing files in the Excel 2007+ XLSX file format. XlsxWriter can be used to write text, numbers, formulas and hyperlinks to multiple worksheets and it supports features such as formatting and many more, including: * 100% compatible Excel XLSX files. * Full formatting. * Merged cells. * Defined names. * Charts. * Autofilters. * Data validation and drop down lists. * Conditional formatting. * Worksheet PNG/JPEG/BMP/WMF/EMF images. * Rich multi-format strings. * Cell comments. * Integration with Pandas. * Textboxes. * Support for adding Macros. * Memory optimization mode for writing large files. It supports Python 2.7, 3.4+ and PyPy and uses standard libraries only. Here is a simple example: import xlsxwriter # Create an new Excel file and add a worksheet. workbook = xlsxwriter.Workbook('demo.xlsx') worksheet = workbook.add_worksheet() # Widen the first column to make the text clearer. worksheet.set_column('A:A', 20) # Add a bold format to use to highlight cells. bold = workbook.add_format({'bold': True}) # Write some simple text. worksheet.write('A1', 'Hello') # Text with formatting. worksheet.write('A2', 'World', bold) # Write some numbers, with row/column notation. worksheet.write(2, 0, 123) worksheet.write(3, 0, 123.456) # Insert an image. worksheet.insert_image('B5', 'logo.png') workbook.close() See the full documentation at: https://xlsxwriter.readthedocs.io Release notes: https://xlsxwriter.readthedocs.io/changes.html %package -n python3-XlsxWriter Summary: A Python module for creating Excel XLSX files. Provides: python-XlsxWriter = %{version}-%{release} BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: shadow-utils %description -n python3-XlsxWriter **XlsxWriter** is a Python module for writing files in the Excel 2007+ XLSX file format. XlsxWriter can be used to write text, numbers, formulas and hyperlinks to multiple worksheets and it supports features such as formatting and many more, including: * 100% compatible Excel XLSX files. * Full formatting. * Merged cells. * Defined names. * Charts. * Autofilters. * Data validation and drop down lists. * Conditional formatting. * Worksheet PNG/JPEG/BMP/WMF/EMF images. * Rich multi-format strings. * Cell comments. * Integration with Pandas. * Textboxes. * Support for adding Macros. * Memory optimization mode for writing large files. It supports Python 2.7, 3.4+ and PyPy and uses standard libraries only. Here is a simple example: import xlsxwriter # Create an new Excel file and add a worksheet. workbook = xlsxwriter.Workbook('demo.xlsx') worksheet = workbook.add_worksheet() # Widen the first column to make the text clearer. worksheet.set_column('A:A', 20) # Add a bold format to use to highlight cells. bold = workbook.add_format({'bold': True}) # Write some simple text. worksheet.write('A1', 'Hello') # Text with formatting. worksheet.write('A2', 'World', bold) # Write some numbers, with row/column notation. worksheet.write(2, 0, 123) worksheet.write(3, 0, 123.456) # Insert an image. worksheet.insert_image('B5', 'logo.png') workbook.close() See the full documentation at: https://xlsxwriter.readthedocs.io Release notes: https://xlsxwriter.readthedocs.io/changes.html %package help Summary: Development documents and examples for XlsxWriter Provides: python3-XlsxWriter-doc %description help **XlsxWriter** is a Python module for writing files in the Excel 2007+ XLSX file format. XlsxWriter can be used to write text, numbers, formulas and hyperlinks to multiple worksheets and it supports features such as formatting and many more, including: * 100% compatible Excel XLSX files. * Full formatting. * Merged cells. * Defined names. * Charts. * Autofilters. * Data validation and drop down lists. * Conditional formatting. * Worksheet PNG/JPEG/BMP/WMF/EMF images. * Rich multi-format strings. * Cell comments. * Integration with Pandas. * Textboxes. * Support for adding Macros. * Memory optimization mode for writing large files. It supports Python 2.7, 3.4+ and PyPy and uses standard libraries only. Here is a simple example: import xlsxwriter # Create an new Excel file and add a worksheet. workbook = xlsxwriter.Workbook('demo.xlsx') worksheet = workbook.add_worksheet() # Widen the first column to make the text clearer. worksheet.set_column('A:A', 20) # Add a bold format to use to highlight cells. bold = workbook.add_format({'bold': True}) # Write some simple text. worksheet.write('A1', 'Hello') # Text with formatting. worksheet.write('A2', 'World', bold) # Write some numbers, with row/column notation. worksheet.write(2, 0, 123) worksheet.write(3, 0, 123.456) # Insert an image. worksheet.insert_image('B5', 'logo.png') workbook.close() See the full documentation at: https://xlsxwriter.readthedocs.io Release notes: https://xlsxwriter.readthedocs.io/changes.html %prep %autosetup -n XlsxWriter-%{version} %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-XlsxWriter -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Mon Aug 19 2024 Ge Wang <wang__ge@126.com> - 3.2.0-1 - Update package to version 3.2.0 * Fri Oct 27 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 3.1.9-1 - Update package to version 3.1.9 * Tue Jun 20 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 3.1.2-1 - Update package to version 3.1.2 * Thu May 4 2023 wubijie <wubijie@kylinos.cn> - 3.1.0-1 - Update package to version 3.1.0 * Fri Mar 17 2023 wubijie <wubijie@kylinos.cn> - 3.0.9-1 - Update package to version 3.0.9 * Tue Feb 14 2023 wubijie <wubijie@kylinos.cn> - 3.0.8-1 - Update package to version 3.0.8 * Tue Nov 01 2022 wangjunqi <wangjunqi@kylinos.cn> - 3.0.3-1 - Update package to version 3.0.3 * Sat Aug 15 2020 Python_Bot <Python_Bot@openeuler.org> - Package Spec generated
Locations
Projects
Search
Status Monitor
Help
Open Build Service
OBS Manuals
API Documentation
OBS Portal
Reporting a Bug
Contact
Mailing List
Forums
Chat (IRC)
Twitter
Open Build Service (OBS)
is an
openSUSE project
.
浙ICP备2022010568号-2